openSUSE Security Update : openssl (openSUSE-SU-2014:0560-1) (Heartbleed)

High Nessus Plugin ID 75331


The remote openSUSE host is missing a security update.


This is an openssl version update to 1.0.1g.

- The main reason for this upgrade was to be clear about the TLS heartbeat problem know as 'Heartbleed' (CVE-2014-0160). That problem was already fixed in our previous openssl update.


Update the affected openssl packages.

See Also

Plugin Details

Severity: High

ID: 75331

File Name: openSUSE-2014-318.nasl

Version: $Revision: 1.5 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2016/07/08

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libopenssl-devel, p-cpe:/a:novell:opensuse:libopenssl-devel-32bit, p-cpe:/a:novell:opensuse:libopenssl1_0_0, p-cpe:/a:novell:opensuse:libopenssl1_0_0-32bit, p-cpe:/a:novell:opensuse:libopenssl1_0_0-debuginfo, p-cpe:/a:novell:opensuse:libopenssl1_0_0-debuginfo-32bit, p-cpe:/a:novell:opensuse:openssl, p-cpe:/a:novell:opensuse:openssl-debuginfo, p-cpe:/a:novell:opensuse:openssl-debugsource, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/04/11

Exploitable With

Core Impact

Reference Information

CVE: CVE-2014-0160