openSUSE Security Update : net-snmp (openSUSE-SU-2014:0398-1)

Medium Nessus Plugin ID 75300

Synopsis

The remote openSUSE host is missing a security update.

Description

net-snmp was updated to fix potential remote denial of service problems :

- fixed a potential remote denial of service problem within the Linux ICMP-MIB implementation (CVE-2014-2284)(bnc#866942)

- fixed a potential remote denial of service problem inside the snmptrapd Perl trap handler (CVE-2014-2285)(bnc#866942)

Solution

Update the affected net-snmp packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=866942

https://lists.opensuse.org/opensuse-updates/2014-03/msg00060.html

Plugin Details

Severity: Medium

ID: 75300

File Name: openSUSE-2014-227.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libsnmp30, p-cpe:/a:novell:opensuse:libsnmp30-32bit, p-cpe:/a:novell:opensuse:libsnmp30-debuginfo, p-cpe:/a:novell:opensuse:libsnmp30-debuginfo-32bit, p-cpe:/a:novell:opensuse:net-snmp, p-cpe:/a:novell:opensuse:net-snmp-debuginfo, p-cpe:/a:novell:opensuse:net-snmp-debugsource, p-cpe:/a:novell:opensuse:net-snmp-devel, p-cpe:/a:novell:opensuse:net-snmp-devel-32bit, p-cpe:/a:novell:opensuse:net-snmp-python, p-cpe:/a:novell:opensuse:net-snmp-python-debuginfo, p-cpe:/a:novell:opensuse:perl-SNMP, p-cpe:/a:novell:opensuse:perl-SNMP-debuginfo, p-cpe:/a:novell:opensuse:snmp-mibs, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/03/11

Reference Information

CVE: CVE-2014-2284, CVE-2014-2285