openSUSE Security Update : udisks2 (openSUSE-SU-2014:0388-1)

Medium Nessus Plugin ID 75298


The remote openSUSE host is missing a security update.


udisks2 was updated to fix a buffer overflow in mount path parsing. If users have the possibility to create very long mount points, such as with FUSE, they could cause udisksd to crash, or even to run arbitrary code as root with specially crafted mount paths. (bnc#865854, CVE-2014-0004)


Update the affected udisks2 packages.

See Also

Plugin Details

Severity: Medium

ID: 75298

File Name: openSUSE-2014-220.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libudisks2-0, p-cpe:/a:novell:opensuse:libudisks2-0-debuginfo, p-cpe:/a:novell:opensuse:typelib-1_0-UDisks-2_0, p-cpe:/a:novell:opensuse:udisks2, p-cpe:/a:novell:opensuse:udisks2-debuginfo, p-cpe:/a:novell:opensuse:udisks2-debugsource, p-cpe:/a:novell:opensuse:udisks2-devel, p-cpe:/a:novell:opensuse:udisks2-lang, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/03/10

Reference Information

CVE: CVE-2014-0004