openSUSE Security Update : libssh (openSUSE-SU-2014:0366-1)

Low Nessus Plugin ID 75290


The remote openSUSE host is missing a security update.


libssh was updated to fix a random generator reseeding issue when forking multiple servers. Forking multiple servers might under some circumstances get them the same random seed state.


Update the affected libssh packages.

See Also

Plugin Details

Severity: Low

ID: 75290

File Name: openSUSE-2014-208.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libssh-debugsource, p-cpe:/a:novell:opensuse:libssh-devel, p-cpe:/a:novell:opensuse:libssh4, p-cpe:/a:novell:opensuse:libssh4-32bit, p-cpe:/a:novell:opensuse:libssh4-debuginfo, p-cpe:/a:novell:opensuse:libssh4-debuginfo-32bit, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2014/03/14

Reference Information

CVE: CVE-2014-0017