openSUSE Security Update : ruby20 (openSUSE-SU-2013:1834-1)

Medium Nessus Plugin ID 75224


The remote openSUSE host is missing a security update.


the following security issue was fixed in ruby20 :

- fix CVE-2013-4164: heap overflow in float point parsing (bnc#851803) The file CVE-2013-4164.patch contains the patch


Update the affected ruby20 packages.

See Also

Plugin Details

Severity: Medium

ID: 75224

File Name: openSUSE-2013-943.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2015/01/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby20, p-cpe:/a:novell:opensuse:ruby20-debuginfo, p-cpe:/a:novell:opensuse:ruby20-debugsource, p-cpe:/a:novell:opensuse:ruby20-devel, p-cpe:/a:novell:opensuse:ruby20-devel-extra, p-cpe:/a:novell:opensuse:ruby20-doc-ri, p-cpe:/a:novell:opensuse:ruby20-tk, p-cpe:/a:novell:opensuse:ruby20-tk-debuginfo, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2013/11/29

Reference Information

CVE: CVE-2013-4164