openSUSE Security Update : nginx (openSUSE-SU-2013:1745-1)

High Nessus Plugin ID 75210


The remote openSUSE host is missing a security update.


The nginx webserver was fixed to avoid a restriction bypass when a space in not correctly escaped. (CVE-2013-4547)

On openSUSE 12.2, nginx was updated to version 1.4.4 stable

- CVE-2013-4547 a character following an unescaped space in a request line was handled incorrectly [bnc#851295]

- bugfix: segmentation fault might occur in the spdy module

- bugfix: segmentation fault might occur on start if if the 'try_files' directive was used with an empty parameter.


Update the affected nginx packages.

See Also

Plugin Details

Severity: High

ID: 75210

File Name: openSUSE-2013-882.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nginx, p-cpe:/a:novell:opensuse:nginx-debuginfo, p-cpe:/a:novell:opensuse:nginx-debugsource, cpe:/o:novell:opensuse:12.3, cpe:/o:novell:opensuse:13.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/11/20

Reference Information

CVE: CVE-2013-4547

BID: 63814