openSUSE Security Update : mariadb (openSUSE-SU-2013:0011-1)

Medium Nessus Plugin ID 75141

Synopsis

The remote openSUSE host is missing a security update.

Description

MariaDB was updated to 5.5.28a, fixing bugs and security issues :

- Release notes:
http://kb.askmonty.org/v/mariadb-5528a-release-notes http://kb.askmonty.org/v/mariadb-5528-release-notes http://kb.askmonty.org/v/mariadb-5527-release-notes

- Changelog:
http://kb.askmonty.org/v/mariadb-5528a-changelog http://kb.askmonty.org/v/mariadb-5528-changelog http://kb.askmonty.org/v/mariadb-5527-changelog

Solution

Update the affected mariadb packages.

See Also

https://mariadb.com/kb/en/library/mariadb-5527-changelog/

https://mariadb.com/kb/en/library/mariadb-5527-release-notes/

https://mariadb.com/kb/en/library/mariadb-5528-changelog/

https://mariadb.com/kb/en/library/mariadb-5528-release-notes/

https://mariadb.com/kb/en/library/mariadb-5528a-changelog/

https://mariadb.com/kb/en/library/mariadb-5528a-release-notes/

https://bugzilla.novell.com/show_bug.cgi?id=779476

https://bugzilla.novell.com/show_bug.cgi?id=792444

https://lists.opensuse.org/opensuse-updates/2013-01/msg00003.html

Plugin Details

Severity: Medium

ID: 75141

File Name: openSUSE-2013-6.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/12/18

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libmariadbclient18, p-cpe:/a:novell:opensuse:libmariadbclient18-32bit, p-cpe:/a:novell:opensuse:libmariadbclient18-debuginfo, p-cpe:/a:novell:opensuse:libmariadbclient18-debuginfo-32bit, p-cpe:/a:novell:opensuse:libmariadbclient_r18, p-cpe:/a:novell:opensuse:libmariadbclient_r18-32bit, p-cpe:/a:novell:opensuse:mariadb, p-cpe:/a:novell:opensuse:mariadb-bench, p-cpe:/a:novell:opensuse:mariadb-bench-debuginfo, p-cpe:/a:novell:opensuse:mariadb-client, p-cpe:/a:novell:opensuse:mariadb-client-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debug-version, p-cpe:/a:novell:opensuse:mariadb-debug-version-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debuginfo, p-cpe:/a:novell:opensuse:mariadb-debugsource, p-cpe:/a:novell:opensuse:mariadb-errormessages, p-cpe:/a:novell:opensuse:mariadb-test, p-cpe:/a:novell:opensuse:mariadb-test-debuginfo, p-cpe:/a:novell:opensuse:mariadb-tools, p-cpe:/a:novell:opensuse:mariadb-tools-debuginfo, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/12/23

Reference Information

CVE: CVE-2012-4414, CVE-2012-5611