openSUSE Security Update : ruby (openSUSE-SU-2013:1393-1)

Medium Nessus Plugin ID 75128


The remote openSUSE host is missing a security update.


The ruby gemrc configured the gem installation source as http source, allowing man in the middle attacks (if someone could provide a different address for


Update the affected ruby packages.

See Also

Plugin Details

Severity: Medium

ID: 75128

File Name: openSUSE-2013-668.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby, p-cpe:/a:novell:opensuse:ruby-common, p-cpe:/a:novell:opensuse:ruby-devel, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2013/08/22

Reference Information

OSVDB: 96330