openSUSE Security Update : libXrender (openSUSE-SU-2013:1011-1)

Medium Nessus Plugin ID 75030

Synopsis

The remote openSUSE host is missing a security update.

Description

This update of libXrender fixes several integer overflow issues.

- U_0001-integer-overflow-in-XRenderQueryFilters-CVE-2013- 198.patch, U_0002-integer-overflow-in-XRenderQueryFormats-CVE-2013- 198.patch, U_0003-integer-overflow-in-XRenderQueryPictIndexValues-C VE-.patch

- integer overflow in XRenderQueryFilters(), XRenderQueryFormats() and XRenderQueryPictIndexValues() [CVE-2013-1987] (bnc#821669, bnc#815451)

Solution

Update the affected libXrender packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=815451

https://bugzilla.novell.com/show_bug.cgi?id=821669

https://lists.opensuse.org/opensuse-updates/2013-06/msg00141.html

Plugin Details

Severity: Medium

ID: 75030

File Name: openSUSE-2013-489.nasl

Version: 1.4

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libXrender-debugsource, p-cpe:/a:novell:opensuse:libXrender-devel, p-cpe:/a:novell:opensuse:libXrender-devel-32bit, p-cpe:/a:novell:opensuse:libXrender1, p-cpe:/a:novell:opensuse:libXrender1-32bit, p-cpe:/a:novell:opensuse:libXrender1-debuginfo, p-cpe:/a:novell:opensuse:libXrender1-debuginfo-32bit, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/06/04

Reference Information

CVE: CVE-2013-1987

BID: 60132