openSUSE Security Update : nagios (openSUSE-SU-2013:0140-1)

High Nessus Plugin ID 74997


The remote openSUSE host is missing a security update.


- avoid stack based buffer overflow in web interface (history): added nagios-history_buffer_overflow.patch - (bnc#797237) fixes CVE-2012-6096


Update the affected nagios packages.

See Also

Plugin Details

Severity: High

ID: 74997

File Name: openSUSE-2013-41.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:nagios, p-cpe:/a:novell:opensuse:nagios-debuginfo, p-cpe:/a:novell:opensuse:nagios-debugsource, p-cpe:/a:novell:opensuse:nagios-devel, p-cpe:/a:novell:opensuse:nagios-www, p-cpe:/a:novell:opensuse:nagios-www-debuginfo, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/01/15

Exploitable With

Core Impact

Metasploit (Nagios3 history.cgi Host Command Execution)

Reference Information

CVE: CVE-2012-6096

OSVDB: 88322