openSUSE Security Update : rubygem-actionpack-2_3 (openSUSE-SU-2013:0662-1)

Medium Nessus Plugin ID 74968


The remote openSUSE host is missing a security update.


Changes in rubygem-actionpack-2_3 :

- add 2 patches to fix security issues :

- bug-809935_2-3-css_sanitize.patch: CVE-2013-1855:
rubygem-actionpack*: XSS vulnerability in sanitize_css in Action Pack (bnc#809935)

- bug-809940_2-3-sanitize_protocol.patch: CVE-2013-1857:
rubygem-actionpack*: XSS Vulnerability in the `sanitize` helper of Ruby on Rails (bnc#809940)


Update the affected rubygem-actionpack-2_3 packages.

See Also

Plugin Details

Severity: Medium

ID: 74968

File Name: openSUSE-2013-324.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-actionpack-2_3, p-cpe:/a:novell:opensuse:rubygem-actionpack-2_3-testsuite, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2013/04/03

Reference Information

CVE: CVE-2013-1855, CVE-2013-1857

OSVDB: 91452, 91454