openSUSE Security Update : ruby (openSUSE-SU-2013:0603-1)

high Nessus Plugin ID 74955

Synopsis

The remote openSUSE host is missing a security update.

Description

Ruby 1.8 was updated to fix a XML entity expansion denial of service attack (CVE-2013-1821)

Ruby 1.9 was updated to 1.9.3 p392, fixing the same security issues and also :

- update json intree to 1.5.5: Denial of Service and Unsafe Object Creation Vulnerability in JSON CVE-2013-0269

- limit entity expansion text limit to 10kB CVE-2013-1821

- get rid of a SEGV when calling rb_iter_break() from some extention libraries.

- some warning suppressed and smaller fixes

Solution

Update the affected ruby packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=803342

https://bugzilla.novell.com/show_bug.cgi?id=808137

https://lists.opensuse.org/opensuse-updates/2013-04/msg00034.html

Plugin Details

Severity: High

ID: 74955

File Name: openSUSE-2013-298.nasl

Version: 1.6

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/19/2021

Supported Sensors: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ruby, p-cpe:/a:novell:opensuse:ruby-common, p-cpe:/a:novell:opensuse:ruby-debuginfo, p-cpe:/a:novell:opensuse:ruby-debugsource, p-cpe:/a:novell:opensuse:ruby-devel, p-cpe:/a:novell:opensuse:ruby-doc-html, p-cpe:/a:novell:opensuse:ruby-doc-ri, p-cpe:/a:novell:opensuse:ruby-examples, p-cpe:/a:novell:opensuse:ruby-test-suite, p-cpe:/a:novell:opensuse:ruby-tk, p-cpe:/a:novell:opensuse:ruby-tk-debuginfo, p-cpe:/a:novell:opensuse:ruby19, p-cpe:/a:novell:opensuse:ruby19-debuginfo, p-cpe:/a:novell:opensuse:ruby19-debugsource, p-cpe:/a:novell:opensuse:ruby19-devel, p-cpe:/a:novell:opensuse:ruby19-devel-extra, p-cpe:/a:novell:opensuse:ruby19-doc-ri, p-cpe:/a:novell:opensuse:ruby19-tk, p-cpe:/a:novell:opensuse:ruby19-tk-debuginfo, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 3/27/2013

Reference Information

CVE: CVE-2013-0269, CVE-2013-1821