openSUSE Security Update : ImageMagick (openSUSE-SU-2013:0535-1)

Medium Nessus Plugin ID 74943

Synopsis

The remote openSUSE host is missing a security update.

Description

ImageMagick received fixes for a overflow in *png_malloc functions.
(CVE-2012-3437)

Solution

Update the affected ImageMagick packages.

See Also

http://lists.opensuse.org/opensuse-updates/2013-03/msg00101.html

https://bugzilla.novell.com/show_bug.cgi?id=773612

Plugin Details

Severity: Medium

ID: 74943

File Name: openSUSE-2013-251.nasl

Version: $Revision: 1.1 $

Type: local

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ImageMagick, p-cpe:/a:novell:opensuse:ImageMagick-debuginfo, p-cpe:/a:novell:opensuse:ImageMagick-debugsource, p-cpe:/a:novell:opensuse:ImageMagick-devel, p-cpe:/a:novell:opensuse:ImageMagick-devel-32bit, p-cpe:/a:novell:opensuse:ImageMagick-extra, p-cpe:/a:novell:opensuse:ImageMagick-extra-debuginfo, p-cpe:/a:novell:opensuse:libMagick++-devel, p-cpe:/a:novell:opensuse:libMagick++5, p-cpe:/a:novell:opensuse:libMagick++5-debuginfo, p-cpe:/a:novell:opensuse:libMagickCore5, p-cpe:/a:novell:opensuse:libMagickCore5-32bit, p-cpe:/a:novell:opensuse:libMagickCore5-debuginfo, p-cpe:/a:novell:opensuse:libMagickCore5-debuginfo-32bit, p-cpe:/a:novell:opensuse:libMagickWand5, p-cpe:/a:novell:opensuse:libMagickWand5-32bit, p-cpe:/a:novell:opensuse:libMagickWand5-debuginfo, p-cpe:/a:novell:opensuse:libMagickWand5-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-PerlMagick, p-cpe:/a:novell:opensuse:perl-PerlMagick-debuginfo, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2013/03/18

Reference Information

CVE: CVE-2012-3437

OSVDB: 84324