openSUSE Security Update : perl (openSUSE-SU-2013:0497-1)

High Nessus Plugin ID 74932


The remote openSUSE host is missing a security update.


Perl was updated to fix 3 security issues :

- fix rehash denial of service (compute time) [bnc#804415] [CVE-2013-1667]

- improve CGI crlf escaping [bnc#789994] [CVE-2012-5526]

- sanitize input in to avoid code injection [bnc#797060] [CVE-2012-6329]

In openSUSE 12.1 also the following non-security bug was fixed :

- fix IPC::Open3 bug when '-' is used [bnc#755278]


Update the affected perl packages.

See Also

Plugin Details

Severity: High

ID: 74932

File Name: openSUSE-2013-225.nasl

Version: $Revision: 1.8 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2017/09/27

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl, p-cpe:/a:novell:opensuse:perl-32bit, p-cpe:/a:novell:opensuse:perl-base, p-cpe:/a:novell:opensuse:perl-base-32bit, p-cpe:/a:novell:opensuse:perl-base-debuginfo, p-cpe:/a:novell:opensuse:perl-base-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-debuginfo, p-cpe:/a:novell:opensuse:perl-debuginfo-32bit, p-cpe:/a:novell:opensuse:perl-debugsource, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2, cpe:/o:novell:opensuse:12.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/03/11

Exploitable With

Metasploit (TWiki MAKETEXT Remote Command Execution)

Elliot (TWiki 5.1.2 RCE)

Reference Information

CVE: CVE-2012-5526, CVE-2012-6329, CVE-2013-1667

BID: 56562, 56950, 58311

OSVDB: 87613, 88272, 90892