openSUSE Security Update : v8 (openSUSE-SU-2013:1960-1)

high Nessus Plugin ID 74869
New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it is different from CVSS.

VPR Score: 5.9

Synopsis

The remote openSUSE host is missing a security update.

Description

- Update spec-file to fit the changes in V8 (addition of internal ICU)

- Building against system ICU

- Regenerate Makefiles before using them

- Update to 3.22.24.8

- Security fixes (bnc#854473) :

- CVE-2013-6638: Buffer overflow in v8

- CVE-2013-6639: Out of bounds write in v8

- CVE-2013-6640: Out of bounds read in v8

Solution

Update the affected v8 packages.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=854473

https://lists.opensuse.org/opensuse-updates/2013-12/msg00122.html

Plugin Details

Severity: High

ID: 74869

File Name: openSUSE-2013-1025.nasl

Version: 1.6

Type: local

Agent: unix

Published: 6/13/2014

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

Risk Factor: High

VPR Score: 5.9

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libv8-3, p-cpe:/a:novell:opensuse:libv8-3-debuginfo, p-cpe:/a:novell:opensuse:v8-devel, p-cpe:/a:novell:opensuse:v8-private-headers-devel, cpe:/o:novell:opensuse:12.3

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Ease: No known exploits are available

Patch Publication Date: 12/16/2013

Reference Information

CVE: CVE-2013-6638, CVE-2013-6639, CVE-2013-6640