openSUSE Security Update : tomcat6 (openSUSE-SU-2012:1700-1)

Medium Nessus Plugin ID 74854

Synopsis

The remote openSUSE host is missing a security update.

Description

- fix bnc#793394 - bypass of security constraints (CVE-2012-3546)

- apache-tomcat-CVE-2012-3546.patch http://svn.apache.org/viewvc?view=revision&revision=1381 035

- fix bnc#793391 - bypass of CSRF prevention filter (CVE-2012-4431)

- apache-tomcat-CVE-2012-4431.patch http://svn.apache.org/viewvc?view=revision&revision=1394 456

- document how to protect against slowloris DoS (CVE-2012-5568/bnc#791679) in README.SUSE

- fixes bnc#791423 - cnonce tracking weakness (CVE-2012-5885) bnc#791424 - authentication caching weakness (CVE-2012-5886) bnc#791426 - stale nonce weakness (CVE-2012-5887)

- apache-tomcat-CVE-2009-2693-CVE-2009-2901-CVE-2009-2902.
patch http://svn.apache.org/viewvc?view=revision&revision=1380 829

- fix bnc#789406 - HTTP NIO connector OOM DoS via a request with large headers (CVE-2012-2733)

- http://svn.apache.org/viewvc?view=revision&revision=1356208

Solution

Update the affected tomcat6 packages.

See Also

http://svn.apache.org/viewvc?view=revision&revision=1356208

http://svn.apache.org/viewvc?view=revision&revision=1380829

http://svn.apache.org/viewvc?view=revision&revision=1381035

http://svn.apache.org/viewvc?view=revision&revision=1394456

https://bugzilla.novell.com/show_bug.cgi?id=789406

https://bugzilla.novell.com/show_bug.cgi?id=791423

https://bugzilla.novell.com/show_bug.cgi?id=791424

https://bugzilla.novell.com/show_bug.cgi?id=791426

https://bugzilla.novell.com/show_bug.cgi?id=791679

https://bugzilla.novell.com/show_bug.cgi?id=793391

https://bugzilla.novell.com/show_bug.cgi?id=793394

https://lists.opensuse.org/opensuse-updates/2012-12/msg00061.html

Plugin Details

Severity: Medium

ID: 74854

File Name: openSUSE-2012-884.nasl

Version: 1.3

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libtcnative-1-0, p-cpe:/a:novell:opensuse:libtcnative-1-0-debuginfo, p-cpe:/a:novell:opensuse:libtcnative-1-0-debugsource, p-cpe:/a:novell:opensuse:libtcnative-1-0-devel, p-cpe:/a:novell:opensuse:tomcat6, p-cpe:/a:novell:opensuse:tomcat6-admin-webapps, p-cpe:/a:novell:opensuse:tomcat6-docs-webapp, p-cpe:/a:novell:opensuse:tomcat6-el-1_0-api, p-cpe:/a:novell:opensuse:tomcat6-javadoc, p-cpe:/a:novell:opensuse:tomcat6-jsp-2_1-api, p-cpe:/a:novell:opensuse:tomcat6-lib, p-cpe:/a:novell:opensuse:tomcat6-servlet-2_5-api, p-cpe:/a:novell:opensuse:tomcat6-webapps, cpe:/o:novell:opensuse:12.1

Patch Publication Date: 2012/12/18

Reference Information

CVE: CVE-2009-2693, CVE-2009-2901, CVE-2009-2902, CVE-2012-2733, CVE-2012-3546, CVE-2012-4431, CVE-2012-5568, CVE-2012-5885, CVE-2012-5886, CVE-2012-5887

CWE: 22, 264