openSUSE Security Update : Hyper-V (openSUSE-SU-2012:1526-1)

Low Nessus Plugin ID 74818


The remote openSUSE host is missing a security update.


This update fixes the following issues for Hyper-V: The source code without this patch caused hv_kvp_daemon to exit when it processed a spoofed Netlink packet which has been sent from an untrusted local user. Now Netlink messages with a non-zero nl_pid source address are ignored and a warning is printed into the syslog.

This fixes the previous change from CVE-2012-2669.


Update the affected Hyper-V packages.

See Also

Plugin Details

Severity: Low

ID: 74818

File Name: openSUSE-2012-799.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:hyper-v, p-cpe:/a:novell:opensuse:hyper-v-debuginfo, p-cpe:/a:novell:opensuse:hyper-v-debugsource, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/11/13

Reference Information

CVE: CVE-2012-2669