openSUSE Security Update : icedtea-web (openSUSE-SU-2012:1524-1)

Medium Nessus Plugin ID 74816


The remote openSUSE host is missing a security update.


The IcedTea Web Java plugin was updated to 1.3.1 (bnc#787846)

- Security Updates

- CVE-2012-4540, RH869040: Heap-based buffer overflow after triggering event attached to applet

- Common Bugfixes

- PR1161: X509VariableTrustManager does not work correctly with OpenJDK7 fixes the self-signed issue (mentioned in bnc#784859, bnc#785333, bnc#786775)


Update the affected icedtea-web packages.

See Also

Plugin Details

Severity: Medium

ID: 74816

File Name: openSUSE-2012-797.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:icedtea-web, p-cpe:/a:novell:opensuse:icedtea-web-debuginfo, p-cpe:/a:novell:opensuse:icedtea-web-debugsource, p-cpe:/a:novell:opensuse:icedtea-web-javadoc, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/11/14

Reference Information

CVE: CVE-2012-4540