openSUSE Security Update : plib (openSUSE-SU-2012:1506-1)

High Nessus Plugin ID 74811


The remote openSUSE host is missing a security update.


This update of plib fixed two stack-based buffer overflows.


Update the affected plib packages.

See Also

Plugin Details

Severity: High

ID: 74811

File Name: openSUSE-2012-789.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 9.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:plib, p-cpe:/a:novell:opensuse:plib-debuginfo, p-cpe:/a:novell:opensuse:plib-debugsource, p-cpe:/a:novell:opensuse:plib-devel, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/11/05

Reference Information

CVE: CVE-2011-4620, CVE-2012-4552