openSUSE Security Update : cgit (openSUSE-SU-2012:1460-1)

Medium Nessus Plugin ID 74805


The remote openSUSE host is missing a security update.


Specially crafted commits can cause code to be executed on the clients due to improperly quoted arguments.


Update the affected cgit packages.

See Also

Plugin Details

Severity: Medium

ID: 74805

File Name: openSUSE-2012-764.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/08/16

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6

Vector: CVSS2#AV:N/AC:M/Au:S/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:cgit, p-cpe:/a:novell:opensuse:cgit-debuginfo, p-cpe:/a:novell:opensuse:cgit-debugsource, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/10/29

Reference Information

CVE: CVE-2012-4548