openSUSE Security Update : mcrypt (openSUSE-SU-2012:1440-1)

Medium Nessus Plugin ID 74803


The remote openSUSE host is missing a security update.


Some potential mcrypt buffer overflows in the commandline tool were fixed, which could lead to early aborts of mcrypt. Due to FORTIFY_SOURCE catching such cases, it would have only aborted mcrypt with a buffer overflow backtrace.


Update the affected mcrypt packages.

See Also

Plugin Details

Severity: Medium

ID: 74803

File Name: openSUSE-2012-758.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:mcrypt, p-cpe:/a:novell:opensuse:mcrypt-debuginfo, p-cpe:/a:novell:opensuse:mcrypt-debugsource, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1, cpe:/o:novell:opensuse:12.2

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/11/02

Reference Information

CVE: CVE-2012-4527