openSUSE Security Update : ghostscript (openSUSE-SU-2012:1289-1)

Medium Nessus Plugin ID 74770


The remote openSUSE host is missing a security update.


The following security issue was fixed in ghostscript :

Multiple integer underflows in the icmLut_allocate function in International Color Consortium (ICC) Format library (icclib), as used in Ghostscript 9.06 and Argyll Color Management System, allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted (1) PostScript or (2) PDF file with embedded images, which triggers a heap-based buffer overflow. NOTE:
this issue is also described as an array index error.


Update the affected ghostscript packages.

See Also

Plugin Details

Severity: Medium

ID: 74770

File Name: openSUSE-2012-668.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:ghostscript-devel, p-cpe:/a:novell:opensuse:ghostscript-fonts-other, p-cpe:/a:novell:opensuse:ghostscript-fonts-rus, p-cpe:/a:novell:opensuse:ghostscript-fonts-std, p-cpe:/a:novell:opensuse:ghostscript-ijs-devel, p-cpe:/a:novell:opensuse:ghostscript-library, p-cpe:/a:novell:opensuse:ghostscript-library-debuginfo, p-cpe:/a:novell:opensuse:ghostscript-library-debugsource, p-cpe:/a:novell:opensuse:ghostscript-x11, p-cpe:/a:novell:opensuse:ghostscript-x11-debuginfo, p-cpe:/a:novell:opensuse:libgimpprint, p-cpe:/a:novell:opensuse:libgimpprint-debuginfo, p-cpe:/a:novell:opensuse:libgimpprint-devel, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/09/25

Reference Information

CVE: CVE-2012-4405