openSUSE Security Update : perl-YAML-LibYAML (openSUSE-SU-2012:1000-1)

Medium Nessus Plugin ID 74717


The remote openSUSE host is missing a security update.


This update of perl-YAML-LibYAML fixed multiple format string flaws that could cause a crash or potentially allow the execution of arbitrary code.


Update the affected perl-YAML-LibYAML packages.

See Also

Plugin Details

Severity: Medium

ID: 74717

File Name: openSUSE-2012-521.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 5

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:perl-YAML-LibYAML, p-cpe:/a:novell:opensuse:perl-YAML-LibYAML-debuginfo, p-cpe:/a:novell:opensuse:perl-YAML-LibYAML-debugsource, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/08/07

Reference Information

CVE: CVE-2012-1152

OSVDB: 79976