openSUSE Security Update : rubygem-actionpack/activerecord-2_3 (openSUSE-SU-2012:0978-1)

High Nessus Plugin ID 74710


The remote openSUSE host is missing a security update.


3 Security issues were fixed in rails 2.3 core components.

2 NULL query issues where fixed in the actionpack gem. 1 SQL injection was fixed in the activerecord gem.


Update the affected rubygem-actionpack/activerecord-2_3 packages.

See Also

Plugin Details

Severity: High

ID: 74710

File Name: openSUSE-2012-508.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2016/04/28

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:rubygem-actionpack-2_3, p-cpe:/a:novell:opensuse:rubygem-actionpack-2_3-testsuite, p-cpe:/a:novell:opensuse:rubygem-activerecord-2_3, p-cpe:/a:novell:opensuse:rubygem-activerecord-2_3-testsuite, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2012/08/02

Reference Information

CVE: CVE-2012-2660, CVE-2012-2694, CVE-2012-2695

OSVDB: 82403, 82610