openSUSE Security Update : puppet (openSUSE-SU-2012:0891-1)

Medium Nessus Plugin ID 74684


The remote openSUSE host is missing a security update.


puppet was updated to fix various security issues: CVEs fixed :

- bnc#770828 - CVE-2012-3864: puppet: authenticated clients can read arbitrary files via a flaw in puppet master

- bnc#770829 - CVE-2012-3865: puppet: arbitrary file delete / Denial of Service on Puppet Master by authenticated clients

- bnc#770827 - CVE-2012-3866: puppet: last_run_report.yaml left world-readable

- bnc#770833 - CVE-2012-3867: puppet: insufficient input validation for agent certificate names

- using the new stable version, 2.6.17, which only receives security fixes.

- Removed runlevel 4.


Update the affected puppet packages.

See Also

Plugin Details

Severity: Medium

ID: 74684

File Name: openSUSE-2012-407.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:puppet, p-cpe:/a:novell:opensuse:puppet-server, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/07/11

Reference Information

CVE: CVE-2012-3864, CVE-2012-3865, CVE-2012-3866, CVE-2012-3867

OSVDB: 83692, 83693, 83694, 83695