openSUSE Security Update : gypsy (openSUSE-SU-2012:0884-1)

Low Nessus Plugin ID 74681


The remote openSUSE host is missing a security update.


The following changes have been made :

- Add gypsy-CVE-2011-0523.patch: add config file to restrict the files that can be read. Fix CVE-2011-0523 and bnc#666839.

- Add gypsy-CVE-2011-0524.patch: use snprintf() to avoid buffer overflows. Fix CVE-2011-0524 and bnc#666839.

- Add gnome-common BuildRequires and call to for gypsy-CVE-2011-0523.patch, since it touches the build system.


Update the affected gypsy packages.

See Also

Plugin Details

Severity: Low

ID: 74681

File Name: openSUSE-2012-394.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/07/17

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 2.1

Vector: CVSS2#AV:L/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:gypsy, p-cpe:/a:novell:opensuse:gypsy-debuginfo, p-cpe:/a:novell:opensuse:gypsy-debugsource, p-cpe:/a:novell:opensuse:libgypsy-devel, p-cpe:/a:novell:opensuse:libgypsy0, p-cpe:/a:novell:opensuse:libgypsy0-debuginfo, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/07/10

Reference Information

CVE: CVE-2011-0523, CVE-2011-0524

OSVDB: 84054, 84055