openSUSE Security Update : libvpx (openSUSE-SU-2012:0759-1)

Medium Nessus Plugin ID 74653


The remote openSUSE host is missing a security update.


A buffer overread was fixed in libvpx which could lead to crashes of applications using libvpx.


Update the affected libvpx packages.

See Also

Plugin Details

Severity: Medium

ID: 74653

File Name: openSUSE-2012-331.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 4.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:libvpx-debugsource, p-cpe:/a:novell:opensuse:libvpx-devel, p-cpe:/a:novell:opensuse:libvpx0, p-cpe:/a:novell:opensuse:libvpx0-debuginfo, p-cpe:/a:novell:opensuse:vpx-tools, p-cpe:/a:novell:opensuse:vpx-tools-debuginfo, cpe:/o:novell:opensuse:11.4

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/06/08

Reference Information

CVE: CVE-2010-4489

OSVDB: 69668