openSUSE Security Update : wireshark (openSUSE-SU-2012:0657-1)

Low Nessus Plugin ID 74636


The remote openSUSE host is missing a security update.


This update is a maintenance release of Wireshark. It fixes some vulererabilities when dissecting certain protocols. As packages for these protocols may be received over the network, an attacker may trigger infinite or large loops or crashes of the dissector. Wireshark release notes and advisories :



- CVE-2012-2392


- CVE-2012-2393


- CVE-2012-2394


Update the affected wireshark packages.

See Also

Plugin Details

Severity: Low

ID: 74636

File Name: openSUSE-2012-297.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 3.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:wireshark, p-cpe:/a:novell:opensuse:wireshark-debuginfo, p-cpe:/a:novell:opensuse:wireshark-debugsource, p-cpe:/a:novell:opensuse:wireshark-devel, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/05/25

Reference Information

CVE: CVE-2012-2392, CVE-2012-2393, CVE-2012-2394

OSVDB: 82098, 82099, 82100, 82154, 82155, 82156, 82157, 82158, 82159, 82160