openSUSE Security Update : freetype2 (openSUSE-SU-2012:0489-1)

Critical Nessus Plugin ID 74597

Synopsis

The remote openSUSE host is missing a security update.

Description

Specially crafted font files could cause buffer overflows in freetype

Solution

Update the affected freetype2 packages.

See Also

https://lists.opensuse.org/opensuse-updates/2012-04/msg00029.html

Plugin Details

Severity: Critical

ID: 74597

File Name: openSUSE-2012-220.nasl

Version: 1.2

Type: local

Agent: unix

Published: 2014/06/13

Updated: 2018/11/10

Dependencies: 12634

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:freetype2-debugsource, p-cpe:/a:novell:opensuse:freetype2-devel, p-cpe:/a:novell:opensuse:freetype2-devel-32bit, p-cpe:/a:novell:opensuse:libfreetype6, p-cpe:/a:novell:opensuse:libfreetype6-32bit, p-cpe:/a:novell:opensuse:libfreetype6-debuginfo, p-cpe:/a:novell:opensuse:libfreetype6-debuginfo-32bit, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2012/03/29

Reference Information

CVE: CVE-2012-1126, CVE-2012-1127, CVE-2012-1128, CVE-2012-1129, CVE-2012-1130, CVE-2012-1131, CVE-2012-1132, CVE-2012-1133, CVE-2012-1134, CVE-2012-1135, CVE-2012-1136, CVE-2012-1137, CVE-2012-1138, CVE-2012-1139, CVE-2012-1140, CVE-2012-1141, CVE-2012-1142, CVE-2012-1143, CVE-2012-1144