openSUSE Security Update : flash-player (openSUSE-SU-2012:0427-1)

Critical Nessus Plugin ID 74582


The remote openSUSE host is missing a security update.


Adobe Flash Player fixes a memory corruption vulnerability in the NetStream class that could lead to code execution


Update the affected flash-player packages.

See Also

Plugin Details

Severity: Critical

ID: 74582

File Name: openSUSE-2012-184.nasl

Version: $Revision: 1.2 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2015/08/13

Dependencies: 12634

Risk Information

Risk Factor: Critical


Base Score: 10

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:flash-player, p-cpe:/a:novell:opensuse:flash-player-gnome, p-cpe:/a:novell:opensuse:flash-player-kde4, cpe:/o:novell:opensuse:11.4, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2012/03/29

Reference Information

CVE: CVE-2012-0773