openSUSE Security Update : FastCGI (openSUSE-2011-102)

High Nessus Plugin ID 74516


The remote openSUSE host is missing a security update.


- added FastCGI-fix_deprecated_api.patch: (bnc#735882) Fixes an issue where received CGI variables from previous requests. CVE-2011-2766


Update the affected FastCGI packages.

See Also

Plugin Details

Severity: High

ID: 74516

File Name: openSUSE-2011-102.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/06/13

Modified: 2014/06/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:opensuse:FastCGI, p-cpe:/a:novell:opensuse:FastCGI-debuginfo, p-cpe:/a:novell:opensuse:FastCGI-debugsource, p-cpe:/a:novell:opensuse:FastCGI-devel, p-cpe:/a:novell:opensuse:perl-FastCGI, p-cpe:/a:novell:opensuse:perl-FastCGI-debuginfo, cpe:/o:novell:opensuse:12.1

Required KB Items: Host/local_checks_enabled, Host/SuSE/release, Host/SuSE/rpm-list, Host/cpu

Patch Publication Date: 2011/12/22

Reference Information

CVE: CVE-2011-2766