ModSecurity < 2.7.6 Chunked Header Filter Bypass

Medium Nessus Plugin ID 73962


The remote web application firewall may be affected by a filter bypass vulnerability.


According to its banner, the version of ModSecurity installed on the remote host is prior to 2.7.6. It is, therefore, potentially affected by a filter bypass vulnerability.

A filter bypass vulnerability exists with 'modsecurity.c' not properly handling chunked requests. A remote attacker, with a specially crafted request, can bypass security filters and inject arbitrary content.

Note that Nessus has not tested for this issue but has instead relied only on the version in the server's banner.


Upgrade to ModSecurity version 2.7.6 or later.

See Also

Plugin Details

Severity: Medium

ID: 73962

File Name: modsecurity_2_7_6.nasl

Version: $Revision: 1.4 $

Type: remote

Family: Firewalls

Published: 2014/05/12

Modified: 2014/09/12

Dependencies: 67123

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:modsecurity:modsecurity

Required KB Items: www/ModSecurity, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2013/12/16

Vulnerability Publication Date: 2013/09/05

Reference Information

CVE: CVE-2013-5705

BID: 66552

OSVDB: 105191