MySQL 5.6.x < 5.6.17 Multiple Vulnerabilities

medium Nessus Plugin ID 73574
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote database server is potentially affected by multiple vulnerabilities.


The version of MySQL installed on the remote host is version 5.6.x prior to 5.6.17. It is, therefore, potentially affected by vulnerabilities in the following components :

- Client
- InnoDB
- Options
- Performance Schema


Upgrade to MySQL 5.6.17 or later.

See Also

Plugin Details

Severity: Medium

ID: 73574

File Name: mysql_5_6_17.nasl

Version: 1.6

Type: remote

Family: Databases

Published: 4/16/2014

Updated: 7/16/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.5


Risk Factor: Medium

Base Score: 6

Temporal Score: 4.4

Vector: AV:N/AC:M/Au:S/C:P/I:P/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/27/2014

Vulnerability Publication Date: 4/15/2014

Reference Information

CVE: CVE-2014-2430, CVE-2014-2431, CVE-2014-2435, CVE-2014-2436, CVE-2014-2440

BID: 66850, 66853, 66858, 66890, 66896