Flash Player for Mac <= 11.7.700.272 / 12.0.0.77 Multiple Vulnerabilities (APSB14-09) (Mac OS X)

High Nessus Plugin ID 73435

Synopsis

The remote Mac OS X host has a browser plugin that is affected by multiple vulnerabilities.

Description

According to its version, the instance of Flash Player installed on the remote Mac OS X host is equal or prior to 11.7.700.272 / 11.8.x / 11.9.x / 12.0.0.77. It is, therefore, potentially affected by multiple vulnerabilities :

- A use-after-free error exists that could lead to arbitrary code execution. (CVE-2014-0506)

- A buffer overflow error exists that could lead to arbitrary code execution. (CVE-2014-0507)

- An unspecified error exists that could allow a security bypass leading to information disclosure.
(CVE-2014-0508)

- An unspecified error exists that could allow cross- site scripting attacks. (CVE-2014-0509)

Solution

Upgrade to Adobe Flash Player version 11.7.700.275 / 13.0.0.182 or later.

See Also

https://helpx.adobe.com/security/products/flash-player/apsb14-09.html

Plugin Details

Severity: High

ID: 73435

File Name: macosx_flash_player_13_0_0_182.nasl

Version: 1.7

Type: local

Agent: macosx

Published: 2014/04/09

Updated: 2018/07/14

Dependencies: 53914

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:flash_player

Required KB Items: MacOSX/Flash_Player/Version

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/04/08

Vulnerability Publication Date: 2014/03/27

Reference Information

CVE: CVE-2014-0506, CVE-2014-0507, CVE-2014-0508, CVE-2014-0509

BID: 66208, 66699, 66701, 66703

CWE: 20, 74, 79, 442, 629, 711, 712, 722, 725, 750, 751, 800, 801, 809, 811, 864, 900, 928, 931, 990