Squid 3.1.x < 3.3.12 / 3.4.4 HTTPS Request Handling DoS

Medium Nessus Plugin ID 73131


The remote proxy server is affected by a denial of service vulnerability.


According to its banner, the version of Squid running on the remote host is 3.x prior to 3.3.12 or 3.4.4 and is, therefore, affected by a denial of service vulnerability.

A flaw exists in SSL-Bump in regards to the state management when processing range requests. A remote attacker can cause the server to crash with specially crafted HTTPS requests.

Note that Nessus has relied only on the version in the proxy server's banner, which is not updated by the patch the project has released to address the issue. If this patch has been applied properly and the service has been restarted, consider this to be a false positive.


Either upgrade to Squid version 3.3.12 / 3.4.4 or later, or apply the vendor-supplied patch.

See Also




Plugin Details

Severity: Medium

ID: 73131

File Name: squid_3_4_4.nasl

Version: $Revision: 1.3 $

Type: remote

Family: Firewalls

Published: 2014/03/21

Modified: 2016/05/12

Dependencies: 49692

Risk Information

Risk Factor: Medium


Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/a:squid-cache:squid

Required KB Items: www/squid, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/03/09

Vulnerability Publication Date: 2014/03/09

Reference Information

CVE: CVE-2014-0128

BID: 66112

OSVDB: 104375