SuSE 11.3 Security Update : libssh2 (SAT Patch Number 8982)

Low Nessus Plugin ID 73130


The remote SuSE 11 host is missing a security update.


This update of libssh fixes the following security issue :

- When libssh operates in server mode, the randomness pool was not switched on fork, so two pools could operate on the same randomness and could generate the same keys.


Apply SAT patch number 8982.

See Also

Plugin Details

Severity: Low

ID: 73130

File Name: suse_11_libssh2-140307.nasl

Version: $Revision: 1.1 $

Type: local

Agent: unix

Published: 2014/03/21

Modified: 2014/03/21

Dependencies: 12634

Risk Information

Risk Factor: Low


Base Score: 1.9

Vector: CVSS2#AV:L/AC:M/Au:N/C:P/I:N/A:N

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:libssh2, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 2014/03/07

Reference Information

CVE: CVE-2014-0017