Wireshark 1.10.x < 1.10.6 Multiple Vulnerabilities

High Nessus Plugin ID 72942


The remote Windows host contains an application that is affected by multiple vulnerabilities.


The installed version of Wireshark 1.10.x is a version prior to 1.10.6. It is, therefore, affected by denial of service vulnerabilities in the following dissectors :

- NFS dissector (CVE-2014-2281)
- M3UA dissector (CVE-2014-2282)
- RLC dissector (CVE-2014-2283)

Additionally, a flaw exists in the 'mpeg_read()' function in the MPEG file parser, 'wiretap/mpeg.c', where input is not properly sanitized when handling oversized records. A context-dependent attacker could cause a buffer overflow with a specially crafted packet trace file, resulting in a denial of service or potentially arbitrary code execution. (CVE-2014-2299)


Upgrade to Wireshark version 1.10.6 or later.

See Also






Plugin Details

Severity: High

ID: 72942

File Name: wireshark_1_10_6.nasl

Version: $Revision: 1.8 $

Type: local

Agent: windows

Family: Windows

Published: 2014/03/11

Modified: 2014/06/22

Dependencies: 34112

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:wireshark:wireshark

Required KB Items: SMB/Wireshark/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/03/07

Vulnerability Publication Date: 2014/03/07

Exploitable With

Core Impact

Metasploit (Wireshark wiretap/mpeg.c Stack Buffer Overflow)

Reference Information

CVE: CVE-2014-2281, CVE-2014-2282, CVE-2014-2283, CVE-2014-2299

BID: 66066, 66068, 66070, 66072

OSVDB: 104196, 104197, 104198, 104199