MariaDB 10 < 10.0.9 Multiple DoS Vulnerabilities

medium Nessus Plugin ID 72713

Synopsis

The remote database server is affected by multiple denial of service vulnerabilities.

Description

The version of MariaDB 10 running on the remote host is a version prior to 10.0.9. It is, therefore, potentially affected by denial of service vulnerabilities that can be exploited by authenticated, remote attackers. These vulnerabilities are due to errors in several components, including the following:

- Partition (CVE-2014-2419)
- Replication (CVE-2014-2438)
- XML (CVE-2014-0384) Note that Nessus has not tested for this issue but has instead relied only on the application's self-reported version number.

Solution

Upgrade to MariaDB version 10.0.9 or later.

See Also

https://mariadb.com/kb/en/mariadb-1009-release-notes

Plugin Details

Severity: Medium

ID: 72713

File Name: mariadb_10_0_9.nasl

Version: 1.12

Type: remote

Family: Databases

Published: 9/17/2019

Updated: 10/21/2019

Configuration: Enable paranoid mode

Risk Information

CVSS Score Source: CVE-2014-2419

VPR

Risk Factor: Low

Score: 3.7

CVSS v2

Risk Factor: Medium

Base Score: 4

Temporal Score: 3

Vector: AV:N/AC:L/Au:S/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.8

Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mariadb:mariadb

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Patch Publication Date: 3/10/2014

Vulnerability Publication Date: 4/15/2014

Reference Information

CVE: CVE-2014-0384, CVE-2014-2419, CVE-2014-2432, CVE-2014-2438, CVE-2014-4243

BID: 66835, 66880, 66875, 66846, 68611