New! Vulnerability Priority Rating (VPR)
Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.
VPR Score: 5.9
SynopsisThe remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.
DescriptionAccording to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.9. It is, therefore, potentially affected by the following vulnerabilities related to the GD extension :
- A heap-based buffer overflow error exists related to the functions 'gdImageCrop' and 'imagecrop' that could allow denial of service attacks and possibly arbitrary code execution. (CVE-2013-7226)
- An error exists in the function 'gdImageCrop' related to return value checking that could lead to use of NULL pointers and denial of service attacks.
- Multiple integer signedness errors exist in the function 'gdImageCrop' that could allow denial of service attacks and information disclosure.
- A data type checking error exists that could allow information disclosure. (CVE-2014-2020)
Note that this plugin does not attempt to exploit these issues, but instead relies only on PHP's self-reported version number.
SolutionUpgrade to PHP version 5.5.9 or later.