GLSA-201401-20 : Cacti: Multiple vulnerabilities

High Nessus Plugin ID 72075


The remote Gentoo host is missing one or more security-related patches.


The remote host is affected by the vulnerability described in GLSA-201401-20 (Cacti: Multiple vulnerabilities)

Multiple vulnerabilities have been discovered in Cacti. Please review the CVE identifiers referenced below for details.
Impact :

A remote attacker could execute arbitrary SQL commands via specially crafted parameters, execute arbitrary shell code or inject malicious script code.
Workaround :

There is no known workaround at this time.


All Cacti users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose '>=net-analyzer/cacti-0.8.8b'

See Also

Plugin Details

Severity: High

ID: 72075

File Name: gentoo_GLSA-201401-20.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2014/01/22

Modified: 2015/04/13

Dependencies: 12634

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:gentoo:linux:cacti, cpe:/o:gentoo:linux

Required KB Items: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2014/01/21

Reference Information

CVE: CVE-2010-1644, CVE-2010-1645, CVE-2010-2092, CVE-2010-2543, CVE-2010-2544, CVE-2010-2545, CVE-2013-1434, CVE-2013-1435

BID: 37109, 39639, 40149, 40332, 42575, 61657, 61847

GLSA: 201401-20