CVE-2010-1644

MEDIUM

Description

Multiple cross-site scripting (XSS) vulnerabilities in Cacti before 0.8.7f, as used in Red Hat High Performance Computing (HPC) Solution and other products, allow remote attackers to inject arbitrary web script or HTML via the (1) hostname or (2) description parameter to host.php, or (3) the host_id parameter to data_sources.php.

References

http://secunia.com/advisories/41041

http://svn.cacti.net/viewvc?view=rev&revision=5901

http://www.cacti.net/release_notes_0_8_7f.php

http://www.mandriva.com/security/advisories?name=MDVSA-2010:160

http://www.securityfocus.com/archive/1/511393

http://www.securityfocus.com/bid/40332

http://www.vupen.com/english/advisories/2010/1203

http://www.vupen.com/english/advisories/2010/2132

https://bugzilla.redhat.com/show_bug.cgi?id=609093

https://rhn.redhat.com/errata/RHSA-2010-0635.html

Details

Source: MITRE

Published: 2010-08-23

Updated: 2012-02-16

Type: CWE-79

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM