Mandriva Linux Security Advisory : openjpeg (MDVSA-2014:008)

High Nessus Plugin ID 72022

Synopsis

The remote Mandriva Linux host is missing one or more security updates.

Description

Updated openjpeg package fixes security vulnerabilities :

Multiple heap-based buffer overflow flaws were found in OpenJPEG. An attacker could create a specially crafted OpenJPEG image that, when opened, could cause an application using openjpeg to crash or, possibly, execute arbitrary code with the privileges of the user running the application (CVE-2013-6045).

Multiple denial of service flaws were found in OpenJPEG. An attacker could create a specially crafted OpenJPEG image that, when opened, could cause an application using openjpeg to crash (CVE-2013-1447, CVE-2013-6052, CVE-2013-6053, CVE-2013-6887).

Solution

Update the affected lib64openjpeg-devel, lib64openjpeg1 and / or openjpeg packages.

See Also

http://advisories.mageia.org/MGASA-2014-0005.html

Plugin Details

Severity: High

ID: 72022

File Name: mandriva_MDVSA-2014-008.nasl

Version: 1.4

Type: local

Published: 2014/01/20

Updated: 2019/08/02

Dependencies: 12634

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: p-cpe:/a:mandriva:linux:lib64openjpeg-devel, p-cpe:/a:mandriva:linux:lib64openjpeg1, p-cpe:/a:mandriva:linux:openjpeg, cpe:/o:mandriva:business_server:1

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/Mandrake/release, Host/Mandrake/rpm-list

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/01/17

Reference Information

CVE: CVE-2013-1447, CVE-2013-6045, CVE-2013-6052, CVE-2013-6053, CVE-2013-6887

BID: 64109, 64118, 64121, 64140, 64142

MDVSA: 2014:008