PHP 5.5.x < 5.5.8 Multiple Vulnerabilities

Medium Nessus Plugin ID 71928

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 3.6

Synopsis

The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.5.x installed on the remote host is a version prior to 5.5.8. It is, therefore, potentially affected by the following vulnerabilities :

- A heap-based buffer overflow error exists in the file 'ext/date/lib/parse_iso_intervals.c' related to handling DateInterval objects that could allow denial of service attacks. (CVE-2013-6712)

- An integer overflow error exists in the function 'exif_process_IFD_TAG' in the file 'ext/exif/exif.c' that could allow denial of service attacks or arbitrary memory reads. (Bug #65873)

- A use-after-free error exists in the function 'do_soap_call' in the file 'ext/soap/soap.c' related to 'typemap' values and error handling and having unspecified impact. (Bug #66112)

Note that this plugin does not attempt to exploit the vulnerabilities, but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.5.8 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.5.8

Plugin Details

Severity: Medium

ID: 71928

File Name: php_5_5_8.nasl

Version: 1.8

Type: remote

Family: CGI abuses

Published: 2014/01/13

Updated: 2018/09/17

Dependencies: 48243

Risk Information

Risk Factor: Medium

VPR Score: 3.6

CVSS Score Source: CVE-2013-6712

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/01/09

Vulnerability Publication Date: 2013/11/27

Reference Information

CVE: CVE-2013-6712

BID: 64018