PHP 5.4.x < 5.4.24 Multiple Vulnerabilities

Medium Nessus Plugin ID 71927

Synopsis

The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.24. It is, therefore, potentially affected by the following vulnerabilities :

- A heap-based buffer overflow error exists in the file 'ext/date/lib/parse_iso_intervals.c' related to handling DateInterval objects that could allow denial of service attacks. (CVE-2013-6712)

- An integer overflow error exists in the function 'exif_process_IFD_TAG' in the file 'ext/exif/exif.c' that could allow denial of service attacks or arbitrary memory reads. (Bug #65873)

Note that this plugin does not attempt to exploit the vulnerabilities, but instead relies only on PHP's self-reported version number.

Solution

Upgrade to PHP version 5.4.24 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.4.24

Plugin Details

Severity: Medium

ID: 71927

File Name: php_5_4_24.nasl

Version: 1.6

Type: remote

Family: CGI abuses

Published: 2014/01/13

Updated: 2019/11/26

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS Score Source: CVE-2013-6712

CVSS v2.0

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2014/01/09

Vulnerability Publication Date: 2013/11/27

Reference Information

CVE: CVE-2013-6712

BID: 64018