PHP 5.4.x < 5.4.24 Multiple Vulnerabilities

medium Nessus Plugin ID 71927
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote web server uses a version of PHP that is potentially affected by multiple vulnerabilities.


According to its banner, the version of PHP 5.4.x installed on the remote host is a version prior to 5.4.24. It is, therefore, potentially affected by the following vulnerabilities :

- A heap-based buffer overflow error exists in the file 'ext/date/lib/parse_iso_intervals.c' related to handling DateInterval objects that could allow denial of service attacks. (CVE-2013-6712)

- An integer overflow error exists in the function 'exif_process_IFD_TAG' in the file 'ext/exif/exif.c' that could allow denial of service attacks or arbitrary memory reads. (Bug #65873)

Note that this plugin does not attempt to exploit the vulnerabilities, but instead relies only on PHP's self-reported version number.


Upgrade to PHP version 5.4.24 or later.

See Also

Plugin Details

Severity: Medium

ID: 71927

File Name: php_5_4_24.nasl

Version: 1.7

Type: remote

Family: CGI abuses

Published: 1/13/2014

Updated: 1/19/2021

Dependencies: php_version.nasl

Risk Information

CVSS Score Source: CVE-2013-6712


Risk Factor: Low

Score: 3.6


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 1/9/2014

Vulnerability Publication Date: 11/27/2013

Reference Information

CVE: CVE-2013-6712

BID: 64018