SuSE 11.2 Security Update : glibc (SAT Patch Number 8335)

high Nessus Plugin ID 71307
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote SuSE 11 host is missing one or more security updates.

Description

This update for glibc contains the following fixes :

- Fix integer overflows in malloc. (CVE-2013-4332, bnc#839870)

- Fix buffer overflow in glob. (bnc#691365)

- Fix buffer overflow in strcoll. (CVE-2012-4412, bnc#779320)

- Update mount flags in <sys/mount.h>. (bnc#791928)

- Fix buffer overrun in regexp matcher. (CVE-2013-0242, bnc#801246)

- Fix memory leaks in dlopen. (bnc#811979)

- Fix stack overflow in getaddrinfo with many results.
(CVE-2013-1914, bnc#813121)

- Fix check for XEN build in glibc_post_upgrade that causes missing init re-exec. (bnc#818628)

- Don't raise UNDERFLOW in tan/tanf for small but normal argument. (bnc#819347)

- Properly cross page boundary in SSE4.2 implementation of strcmp. (bnc#822210)

- Fix robust mutex handling after fork. (bnc#827811)

- Fix missing character in IBM-943 charset. (bnc#828235)

- Fix use of alloca in gaih_inet. (bnc#828637)

- Initialize pointer guard also in static executables.
(CVE-2013-4788, bnc#830268)

- Fix readdir_r with long file names. (CVE-2013-4237, bnc#834594)

Solution

Apply SAT patch number 8335.

See Also

https://bugzilla.novell.com/show_bug.cgi?id=691365

https://bugzilla.novell.com/show_bug.cgi?id=779320

https://bugzilla.novell.com/show_bug.cgi?id=791928

https://bugzilla.novell.com/show_bug.cgi?id=801246

https://bugzilla.novell.com/show_bug.cgi?id=811979

https://bugzilla.novell.com/show_bug.cgi?id=813121

https://bugzilla.novell.com/show_bug.cgi?id=818628

https://bugzilla.novell.com/show_bug.cgi?id=819347

https://bugzilla.novell.com/show_bug.cgi?id=822210

https://bugzilla.novell.com/show_bug.cgi?id=827811

https://bugzilla.novell.com/show_bug.cgi?id=828235

https://bugzilla.novell.com/show_bug.cgi?id=828637

https://bugzilla.novell.com/show_bug.cgi?id=830268

https://bugzilla.novell.com/show_bug.cgi?id=834594

https://bugzilla.novell.com/show_bug.cgi?id=839870

http://support.novell.com/security/cve/CVE-2012-4412.html

http://support.novell.com/security/cve/CVE-2013-0242.html

http://support.novell.com/security/cve/CVE-2013-1914.html

http://support.novell.com/security/cve/CVE-2013-4237.html

http://support.novell.com/security/cve/CVE-2013-4332.html

http://support.novell.com/security/cve/CVE-2013-4788.html

Plugin Details

Severity: High

ID: 71307

File Name: suse_11_glibc-130913.nasl

Version: 1.3

Type: local

Agent: unix

Published: 12/10/2013

Updated: 1/19/2021

Dependencies: ssh_get_info.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.7

CVSS v2

Risk Factor: High

Base Score: 7.5

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Vulnerability Information

CPE: p-cpe:/a:novell:suse_linux:11:glibc, p-cpe:/a:novell:suse_linux:11:glibc-32bit, p-cpe:/a:novell:suse_linux:11:glibc-devel, p-cpe:/a:novell:suse_linux:11:glibc-devel-32bit, p-cpe:/a:novell:suse_linux:11:glibc-html, p-cpe:/a:novell:suse_linux:11:glibc-i18ndata, p-cpe:/a:novell:suse_linux:11:glibc-info, p-cpe:/a:novell:suse_linux:11:glibc-locale, p-cpe:/a:novell:suse_linux:11:glibc-locale-32bit, p-cpe:/a:novell:suse_linux:11:glibc-profile, p-cpe:/a:novell:suse_linux:11:glibc-profile-32bit, p-cpe:/a:novell:suse_linux:11:nscd, cpe:/o:novell:suse_linux:11

Required KB Items: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

Patch Publication Date: 9/13/2013

Reference Information

CVE: CVE-2012-4412, CVE-2013-0242, CVE-2013-1914, CVE-2013-4237, CVE-2013-4332, CVE-2013-4788