FreeBSD : rails -- multiple vulnerabilities (6a806960-3016-44ed-8575-8614a7cb57c7)

Medium Nessus Plugin ID 71257


The remote FreeBSD host is missing one or more security-related updates.


Rails weblog :

Rails 3.2.16 and 4.0.2 have been released! These two releases contain important security fixes, so please upgrade as soon as possible! In order to make upgrading as smooth as possible, we've only included commits directly related to each security issue.

The security fixes in 3.2.16 are :

- CVE-2013-4491

- CVE-2013-6414

- CVE-2013-6415

- CVE-2013-6417

The security fixes in 4.0.2 are :

- CVE-2013-4491

- CVE-2013-6414

- CVE-2013-6415

- CVE-2013-6416

- CVE-2013-6417


Update the affected packages.

See Also

Plugin Details

Severity: Medium

ID: 71257

File Name: freebsd_pkg_6a806960301644ed85758614a7cb57c7.nasl

Version: $Revision: 1.4 $

Type: local

Published: 2013/12/09

Modified: 2015/01/14

Dependencies: 12634

Risk Information

Risk Factor: Medium


Base Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

Vulnerability Information

CPE: p-cpe:/a:freebsd:freebsd:rubygem-actionmailer, p-cpe:/a:freebsd:freebsd:rubygem-actionpack, p-cpe:/a:freebsd:freebsd:rubygem-actionpack4, p-cpe:/a:freebsd:freebsd:rubygem-activemodel, p-cpe:/a:freebsd:freebsd:rubygem-activerecord, p-cpe:/a:freebsd:freebsd:rubygem-activeresource, p-cpe:/a:freebsd:freebsd:rubygem-activesupport, p-cpe:/a:freebsd:freebsd:rubygem-activesupport4, p-cpe:/a:freebsd:freebsd:rubygem-rails, p-cpe:/a:freebsd:freebsd:rubygem-railties, cpe:/o:freebsd:freebsd

Required KB Items: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

Patch Publication Date: 2013/12/08

Vulnerability Publication Date: 2013/12/03

Reference Information

CVE: CVE-2013-4491, CVE-2013-6414, CVE-2013-6415, CVE-2013-6416, CVE-2013-6417