MySQL 5.1 < 5.1.71 Server Optimizer Denial of Service

Critical Nessus Plugin ID 70461

Synopsis

The remote database server may be affected by a denial of service vulnerability.

Description

The version of MySQL 5.1 installed on the remote host is earlier than 5.1.71. It is, therefore, potentially affected by multiple denial of service vulnerabilities in the 'Server Optimizer' component.

Note: Oracle has provided a workaround to address the issue for CVE-2012-2750.

Solution

Upgrade to MySQL version 5.1.71 or later.

See Also

http://www.nessus.org/u?f2d5fae1

http://dev.mysql.com/doc/relnotes/mysql/5.1/en/news-5-1-71.html

Plugin Details

Severity: Critical

ID: 70461

File Name: mysql_5_1_71.nasl

Version: 1.7

Type: remote

Family: Databases

Published: 2013/10/16

Updated: 2018/11/15

Dependencies: 10719, 91823

Configuration: Enable paranoid mode

Risk Information

Risk Factor: Critical

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:oracle:mysql

Required KB Items: Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/08/01

Vulnerability Publication Date: 2013/10/15

Reference Information

CVE: CVE-2012-2750, CVE-2013-3839

BID: 63109, 63125