Amazon Linux AMI : rubygems (ALAS-2013-230)

medium Nessus Plugin ID 70234

Synopsis

The remote Amazon Linux AMI host is missing a security update.

Description

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

Solution

Run 'yum update rubygems' to update your system.

See Also

https://alas.aws.amazon.com/ALAS-2013-230.html

Plugin Details

Severity: Medium

ID: 70234

File Name: ala_ALAS-2013-230.nasl

Version: 1.5

Type: local

Agent: unix

Published: 10/1/2013

Updated: 4/18/2018

Supported Sensors: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Vulnerability Information

CPE: p-cpe:/a:amazon:linux:rubygems, p-cpe:/a:amazon:linux:rubygems-devel, cpe:/o:amazon:linux

Required KB Items: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

Patch Publication Date: 9/26/2013

Reference Information

CVE: CVE-2013-4287

ALAS: 2013-230