CVE-2013-4287

MEDIUM

Description

Algorithmic complexity vulnerability in Gem::Version::VERSION_PATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

References

http://blog.rubygems.org/2013/09/09/CVE-2013-4287.html

http://rhn.redhat.com/errata/RHSA-2013-1427.html

http://rhn.redhat.com/errata/RHSA-2013-1441.html

http://rhn.redhat.com/errata/RHSA-2013-1523.html

http://rhn.redhat.com/errata/RHSA-2013-1852.html

http://rhn.redhat.com/errata/RHSA-2014-0207.html

http://secunia.com/advisories/55381

http://www.openwall.com/lists/oss-security/2013/09/10/1

https://puppet.com/security/cve/cve-2013-4287

Details

Source: MITRE

Published: 2013-10-17

Updated: 2019-04-22

Type: CWE-310

Risk Information

CVSS v2.0

Base Score: 4.3

Vector: AV:N/AC:M/Au:N/C:N/I:N/A:P

Impact Score: 2.9

Exploitability Score: 8.6

Severity: MEDIUM