Adobe AIR <= 3.7.0.2090 Multiple Vulnerabilities (APSB13-17)

Critical Nessus Plugin ID 70214

Synopsis

The remote Windows host contains a version of Adobe AIR that is affected by multiple vulnerabilities.

Description

According to its version, the instance of Adobe AIR on the remote Windows host is 3.7.0.2090 or earlier. It is, therefore, potentially affected by multiple vulnerabilities :

- A heap-based buffer overflow vulnerability exists that could lead to code execution. (CVE-2013-3344)

- A memory corruption vulnerability exists that could lead to code execution. (CVE-2013-3345)

- An integer overflow exists when resampling a user- supplied PCM buffer. (CVE-2013-3347)

Solution

Upgrade to Adobe AIR 3.8.0.870 or later.

See Also

http://www.adobe.com/support/security/bulletins/apsb13-17.html

Plugin Details

Severity: Critical

ID: 70214

File Name: adobe_air_apsb13-17.nasl

Version: 1.6

Type: local

Agent: windows

Family: Windows

Published: 2013/09/30

Updated: 2019/11/27

Dependencies: 32504

Risk Information

Risk Factor: Critical

CVSS Score Source: CVE-2013-3347

CVSS v2.0

Base Score: 10

Temporal Score: 7.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:adobe:air

Required KB Items: SMB/Adobe_AIR/Version, SMB/Adobe_AIR/Path

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2013/07/09

Vulnerability Publication Date: 2013/07/09

Reference Information

CVE: CVE-2013-3344, CVE-2013-3345, CVE-2013-3347

BID: 61043, 61045, 61048